Pular para o conteúdo principal

Postagens

Tarifa Zero

As manifestações contra os vinte centavos de aumento despertaram uma vastidão de questões sobre a "eficiência" do nosso sistema de governo. As questões mais gerais foram abordadas: das repercursões,  do uso do dinheiro público, etc. Uma das questões originais, defendida pelo MPL (Movimento Passe Livre) é se devemos cobrar tarifas para o transporte público. Numa primeira análise podemos imaginar que a tarifa zero para o transporte público seja um exagero, uma solução populista ineficiente. Populista porque a população teria a impressão que o sistema teria feito algo a seu favor quando na verdade estaria utilizando dinheiro dos impostos para arcar com os custos. Ineficiente porque ... bem porque o governo é um balde furado (Arthur Okun, Equality and Efficiency: The Big Tradeoff). Levar dinheiro de uma área para outra traz ineficiência. Mas essa parece ser mesmo uma conclusão equivocada. A começar que teoricamente, os impostos públicos deveriam ser cobrados de forma progress...

A arrogância dos esnobes

Esse texto é uma compilação de uma discussão minha com o +Fabrício Nascimento   sobre o texto:  A arrogância segundo os medíocres . --- Parecer arrogante é uma falha "linguística", falha em especial do emissor. Quando uma mocinha informa que comprou uma xícara numa feira na Colombia, ela está atribuindo valor a xícara. Óbvio! O item é mais difícil de conseguir, reflete a condição diferenciada dessa locutora; apenas aqueles que viajaram para Colômbia teriam acesso a ele. Se ao contrário, o locutor informar que comprou alguma coisa na 25 de Março está sendo empático e tornando o item acessível (como dizendo que qualquer um poderia te-lo; não há nada que o diferencia). Mas quem decide o que é ser arrogante? O receptor também faz parte da interpretação da mensagem passada pelo emissor e ele pode muito bem interpretar uma arrogância que não estava presente na mensagem inicial. Nesse caso, pode ser falha linguística, que pode advir tanto da má formulação do locutor, mas tam...

Quantização de Imagens

Criei um material no bitbucket  sobre a quantização de imagens. O objetivo é de um estudo maior, que tratará a indexação de metainformações em imagens. Tópicos tratados: Cores dominantes Redução elementar Melhor Representação de uma cor Erro médio na quantização Colorspace Do projeto é  https://bitbucket.org/rdllopes/image-analyzer . Aqui os thumbs do artigo que explica brevemente o projeto: Ah. Deixo aqui meus agradecimentos as ferramentas imagemagick, bitbucket, git, gradle, latex, mathjax, pandoc, que facilitaram tanto esse projeto.

Sobre criaturas e criadores

Me impressiona como toda discussão aqui no Brasil termina numa discussão teológica: o mal versus o bem. Com a questão da maioridade penal não seria diferente.  Claro, o Brasil é tão errado que fazer algum esforço para fazer alguma coisa boa, mas não escandalosamente boa,  é "errado".  Esse é o apelo ao pior problema... A jornalista Eliane Brum é uma dessas pessoas que "acredita" nisso. O texto na íntegra encontra-se aqui . Comentarei trechos de sua parte inicial. Vejamos: Eu acredito na indignação. É dela e do espanto que vêm a vontade de construir um mundo que faça mais sentido, um em que se possa viver sem matar ou morrer. Por isso, diante de um assassinato consumado em São Paulo por um adolescente a três dias de completar 18 anos, minha proposta é de nos indignarmos bastante.  Não para aumentar o rigor da lei para adolescentes, mas para aumentar nosso rigor ao exigir que a lei seja cumprida pelos governantes que querem aumentar o rigor da lei.  Uma cois...

Very short REST client in Ruby

I've studied Ruby for 2 years. I feel Ruby like Lego blocks: it is cool, funny, and you could even build a wall with this easily but it could be expensive to make a very solid wall. Anyway, here is a funny to.  Look how simple is to do a Getter REST client in ruby (you could try RESTfolia, restfulie, etc). I call Getter REST client because, it just for GET requests. require "net/http" require "uri" require 'json' require 'methodize' uri = URI.parse("http://localhost:8080/jdb/list") response = Net::HTTP.get_response(uri) json = JSON.parse(response.body) json.extend(Methodize) With authentication, we get: req = Net::HTTP::Get.new(uri.request_uri) req.basic_auth 'user', 'password' res = Net::HTTP.start(uri.hostname, uri.port) {|http| http.request(req) } json = JSON.parse(res.body) json.extend(Methodize) That is it!

What happens when you click on submit button

HTTP over TCP/IP Suite Maybe someone asks you about what happens when you click on submit button in a web browser. That question is in fact a very recurrent question in interviews for Software Engineers, Web Developers and so on. I  really suggest you take a look at RFC specifications. Before you deep dive into RFCs (Internet Protocol, IP (1981)  - RFC 791; Transfer Control Protocol, TCP - RFC 793; and Hyper Text Transfer Protocol 1.1, HTTP/1.1 - Roy Fielding et al, RFC 2616) I advise you to look at some links before (yeah, it is a hard way to the top if you wanna rock'n'roll): Eventhelix.com has created a very insightful tool to understand network interactions.  Take a look here (you need to have some previous knowledge about network vocabulary): http sequence diagram in pdf Are you very green at HTTP? Ok... here is a good introduction: http_basics (ntu.edu.sg) Always useful to know how to use curl and what the heck is  x-www-form-urlencoded ... ta...